re = /(([\+]90?)|([0]?))([ ]?)((\([0-9]{3}\))|([0-9]{3}))([ ]?)([0-9]{3})(\s*[\-]?)([0-9]{2})(\s*[\-]?)([0-9]{2}|)/
str = '+90 (545) 369 71 22,+90 (545) 369 71 22'
# Print the match result
str.match(re) do |match|
puts match.to_s
end