using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(?=\W|$)|(?<=\W|^)'";
string input = @"'What sscsc don't 'svsdvs' aren't sdsv to?'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}