re = /\b(?!OK)(?i)OK\b/m
str = 'Ok
oK
ok
OK
It\'s not OK but it is Ok or oK or ok
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end