$re = '/^\d+(?:-\d+)?(?:,\s*\d+(?:-\d+)?)*$/m';
$str = '1
1, 4-5
1, 4-5, 8, 11, 13-14
1,,,,
1, 4-5-
1, 4--------2233-----,,,,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);