$re = '/^static.+$(?<!ico)/';
$str = 'static/assets/img/favicon.ico';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);