package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*capital of .+`)
var str = `What is the capital of Kenya?
capital of Kenya?
The capital of Kenya
Kenyan capital`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}