package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([+]?\d{1,4}[-\s]?|)\d{3}[-\s]?\d{3}[-\s]?\d{4}$`)
var str = `0039686320815`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}