$re = '/[1-9][0-9]{0,2}\.[0-9]{1,3}/';
$str = '1.0
999.999
12.21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);