const regex = new RegExp('<[^\\'">]*(("[^"]*"|\\'[^\\']*\\')[^\\'">]*)*>', 'g')
const str = `some text <tag link="fo>o"> other text
some text <tag link="fo>o"> other text
<meta name="keywords" content="javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor" />
<meta name="descrip><>><>tion" content="Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript." />
<meta name="author" content="Firas Dib" />
content content content
content <meta property="twitter:ca><<>>><>><>rd" content="summary" />content content
content content
content content content <meta property="twitter:site" content="@regex101" />content content content content
content content content content
<meta property="twitter:title" content="Regex101 - online regex editor and debugger" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}