re = /window\.location\.redirect\("(.*?)"\)/
str = 'window.location.redirect("http://stackoverflow.com")'
# Print the match result
str.match(re) do |match|
puts match.to_s
end