$re = '/\b[0-9]{1,3}(?:\s\p{L}+)+/m';
$str = '34 44 55 rue du therne, 04 84 98';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);