$re = '/\b(Mar\S*)(?:\s+\S+){0,3}\s*\b(Ant\S*)(?:\s+\S+){0,3}\s*(Ara\S*)/m';
$str = 'Marck SC. Antony L. Aragon
Marcus Anthilope Burton Chase Araujo
And the Cat Marked this on looking at Anti-terror panel in the city of Aragon';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;