$re = '/\b(?=Ja\w*a\b)\w*?((\w)\2+)\w*\b/';
$str = 'Prooo
Javaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);