const regex = new RegExp('^(?P<date>\\S+\\s+\\d\\s\\d\\d:\\d\\d:\\d\\d) (?P<hostname>\\S+) suricata\\[(?P<pid>\\d+)\\]: \\[(?P<sid>\\d+:\\d+:\\d+)\\] (?P<msg>.+) \\[Classification:(?P<classification>.+)\\] \\[Priority:(?P<priority> \\d+)\\] \\{(?P<proto>.+)\\} (?P<src_ip>[\\d.]{7,15}):(?P<src_port>\\d+) -> (?P<dst_ip>[\\d.]{7,15}):(?P<dst_port>\\d+)$', '')
const str = `Jun 2 09:56:56 suribox suricata[56928]: [1:2220006:1] SURICATA SMTP no server welcome message [Classification: Generic Protocol Command Decode] [Priority: 3] {TCP} 1.1.1.1:25 -> 2.2.2.2:28780`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}