$re = '/(\d|\w)\1+/m';
$str = '00000000
aaaaaaaa
aa1123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);