re = /\:\[\]\:.*?\:/m
str = ':[]: Abet1, Abetted34: Find the usage in table under section 1-CB-45: Or more info from the related section starting with PARTIE-DU-CORPS.
:[]: Ou est-ce que tu a mal: Tu as mal aux jambes: Find usage in section 145-TT-LA-TETE.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end