using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s?)\:\/\/[0-9a-zA-Z]([-.\w]*[0-9a-zA-Z])*(:(0-9)*)*(\/?)([a-zA-Z0-9\-\.\?\,\'\/\\\+&%\$#_]*)?(.pdf)$";
string input = @"http://regex101.com/javascript/dfdf/fgfg.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}