const regex = /\(?\+?([0-9]{2})?\s?\(?(11|12|13|14|15|16|17|18|19|21|22|24|27|28|31|32|33|34|35|37|38|41|42|43|44|45|46|47|48|49|51|53|54|55|61|62|63|64|65|66|67|68|69|71|73|74|75|77|79|81|82|83|84|85|86|87|88|89|91|92|93|94|95|96|97|98|99)?\)?\s?(9\s)?([0-9]{8,11})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(?\\+?([0-9]{2})?\\s?\\(?(11|12|13|14|15|16|17|18|19|21|22|24|27|28|31|32|33|34|35|37|38|41|42|43|44|45|46|47|48|49|51|53|54|55|61|62|63|64|65|66|67|68|69|71|73|74|75|77|79|81|82|83|84|85|86|87|88|89|91|92|93|94|95|96|97|98|99)?\\)?\\s?(9\\s)?([0-9]{8,11})', 'gi')
const str = `Atendimento 11 9 77472068 lalala +55 11 9 77472068 espiritual 5511977472068 what (11) 9 77472068 lalala 985344879 kkkkk 2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}