const regex = /\D{4,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D{4,}', 'gm')
const str = `gfhfghk,7878lll,
ytyC2356 -6666fggg
gvvbjh,8787
gvvbjh, co-worker
454556`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}