import re
regex = re.compile(r"https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*", flags=re.IGNORECASE)
test_str = ("https://www.asd.google.com/search?q=some+text¶m=3#dfsdf\n"
"https://www.google.com\n"
"http://google.com/?q=some+text¶m=3#dfsdf\n"
"https://www.google.com/api/?\n"
"https://www.google.com/api/login.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")