$re = '/(?<!or)(?<!and)\s(?!or)(?!and)/';
$str = 'ield = 10 and field2= 100 or field10 is not null';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);