re = /([^\s]+\s[^\s]+)\s+([^\s]+)\s+([^\s]+\s[^\s]+)|([^\s]+\s[^\s]+)\s+([^\s]+\s[^\s]+)/
str = '
hostportservice(192.168.1.241(10001), service(master)) hostportservice(192.168.1.200(10001), service(slave))
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)
hostportservice(192.168.1.241(10001), service(master)) updatedate(24-DEC-2015) updatetime(11:32:57 PM)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end