package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/([^\/]+\/)*(?<servlet>[^\?]+)\?.*`)
var str = `/shop/mystore/ProductDisplay?urlRequestType=Base`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}