# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Data\": )\""
test_str = ("Event 1 : \n"
"=========\n"
"Input Event : [so much data exists in the same single line ] ,\\\"Comments\\\": \\\"New alert\\\", \"Data\": \"{\\\"etype\\\":\\\"MalwareFamily\\\",\\\"at\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"md\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"Investigations\\\":[{\\\"$id\\\":\\\"1\\\",\\\"Id\\\":\\\"urn:ZappedUrlInvestigation:2cc87ae3\\\",\\\"InvestigationStatus\\\":\\\"Running\\\"}],\\\"InvestigationIds\\\":[\\\"urn:ZappedUrlInvestigation:2cc8782d063\\\"],\\\"Intent\\\":\\\"Probing\\\",\\\"ResourceIdentifiers\\\":[{\\\"$id\\\":\\\"2\\\",\\\"AadTenantId\\\":\\\"2dfb29-729c918\\\",\\\"Type\\\":\\\"AAD\\\"}],\\\"AzureResourceId\\\":null,\\\"WorkspaceId\\\":null,\\\"Metadata\\\":{\\\"CustomApps\\\":null,\\\"GenericInfo\\\":null},\\\"Entities\\\":[{\\\"$id\\\":\\\"3\\\",\\\"MailboxPrimaryAddress\\\":\\\"abc@gmail.com\\\",\\\"Upn\\\":\\\"abc@gmail.com\\\",\\\"AadId\\\":\\\"6eac3b76357\\\",\\\"RiskLevel\\\":\\\"None\\\",\\\"Type\\\":\\\"mailbox\\\",\\\"Urn\\\":\\\"urn:UserEntity:10338af2b6c\\\",\\\"Source\\\":\\\"TP\\\",\\\"FirstSeen\\\":\\\"0001-01-01T00:00:00\\\"}, \\\"StartTimeUtc\\\": \\\"2024-06-21T10:12:37\\\", \\\"Status\\\": \\\"Investigation Started\\\"}\",\"EntityType\": \"MalwareFamily\", [so much data exists in the same single line ]\n\n"
"Event 2 : \n"
"=======\n"
"[so much data exists in the same single line ] ,\\\"Comments\\\": \\\"New alert\\\", \"Data\": \"{\\\"etype\\\":\\\"MalwareFamily\\\",\\\"at\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"md\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"Investigations\\\":[{\\\"$id\\\":\\\"1\\\",\\\"Id\\\":\\\"urn:ZappedUrlInvestigation:2cc87ae3\\\",\\\"InvestigationStatus\\\":\\\"Running\\\"}],\\\"InvestigationIds\\\":[\\\"urn:ZappedUrlInvestigation:2cc8782d063\\\"],\\\"Intent\\\":\\\"Probing\\\",\\\"ResourceIdentifiers\\\":[{\\\"$id\\\":\\\"2\\\",\\\"AadTenantId\\\":\\\"2dfb29-729c918\\\",\\\"Type\\\":\\\"AAD\\\"}],\\\"AzureResourceId\\\":null,\\\"WorkspaceId\\\":null,\\\"Metadata\\\":{\\\"CustomApps\\\":null,\\\"GenericInfo\\\":null},\\\"Entities\\\":[{\\\"$id\\\":\\\"3\\\",\\\"MailboxPrimaryAddress\\\":\\\"abc@gmail.com\\\",\\\"Upn\\\":\\\"abc@gmail.com\\\",\\\"AadId\\\":\\\"6eac3b76357\\\",\\\"RiskLevel\\\":\\\"None\\\",\\\"Type\\\":\\\"mailbox\\\",\\\"Urn\\\":\\\"urn:UserEntity:10338af2b6c\\\",\\\"Source\\\":\\\"TP\\\",\\\"FirstSeen\\\":\\\"0001-01-01T00:00:00\\\"}, \\\"StartTimeUtc\\\": \\\"2024-06-21T10:12:37\\\", \\\"Status\\\": \\\"Investigation Started\\\"}\",\"ids\": [9654,\"78b3\"], [so much data exists in the same single line ]\n\n"
"Event 3 : \n"
"==========\n\n"
"[so much data exists in the same single line ] ,\\\"Comments\\\": \\\"New alert\\\", \"Data\": \"{\\\"etype\\\":\\\"MalwareFamily\\\",\\\"at\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"md\\\":\\\"2024-06-21T11:34:07.0000000Z\\\",\\\"Investigations\\\":[{\\\"$id\\\":\\\"1\\\",\\\"Id\\\":\\\"urn:ZappedUrlInvestigation:2cc87ae3\\\",\\\"InvestigationStatus\\\":\\\"Running\\\"}],\\\"InvestigationIds\\\":[\\\"urn:ZappedUrlInvestigation:2cc8782d063\\\"],\\\"Intent\\\":\\\"Probing\\\",\\\"ResourceIdentifiers\\\":[{\\\"$id\\\":\\\"2\\\",\\\"AadTenantId\\\":\\\"2dfb29-729c918\\\",\\\"Type\\\":\\\"AAD\\\"}],\\\"AzureResourceId\\\":null,\\\"WorkspaceId\\\":null,\\\"Metadata\\\":{\\\"CustomApps\\\":null,\\\"GenericInfo\\\":null},\\\"Entities\\\":[{\\\"$id\\\":\\\"3\\\",\\\"MailboxPrimaryAddress\\\":\\\"abc@gmail.com\\\",\\\"Upn\\\":\\\"abc@gmail.com\\\",\\\"AadId\\\":\\\"6eac3b76357\\\",\\\"RiskLevel\\\":\\\"None\\\",\\\"Type\\\":\\\"mailbox\\\",\\\"Urn\\\":\\\"urn:UserEntity:10338af2b6c\\\",\\\"Source\\\":\\\"TP\\\",\\\"FirstSeen\\\":\\\"0001-01-01T00:00:00\\\"}, \\\"StartTimeUtc\\\": \\\"2024-06-21T10:12:37\\\", \\\"Status\\\": \\\"Investigation Started\\\"}\",\"Name\": \"Phishing Categroy\", [so much data exists in the same single line ]\n\n"
"======\n\n")
subst = "$1["
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.