re = /(?<=\s)([^=]+)="([^"]+)"/
str = '<?UMBRACO_MACRO redirectto="/sagen.aspx" loginpage="/Login.aspx" macroAlias="BrowserValidation" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end