$re = '/^.*:(?!jar)/m';
$str = 'com.test.api:super.duper-api:jar:1.2.3:compile';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);