using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0]{1}[1-9]{1}|[1-9]{1}[0-9]{1})[0-9]{3}$";
string input = @"48565";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}