re = /^(-?\d+(em|ex|%|px|cm|mm|in|pt|pc|ch|rem|vh|vw|vmin|vmax)|0)$/i
str = '-30%'
# Print the match result
str.match(re) do |match|
puts match.to_s
end