$re = '/^(?=.*1)[01]+$/';
$str = '001101101';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);