$re = '/\s{2,}/m';
$str = 'fernando and search ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;