# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\buk:.+?,Page)(?:,|$)//gis;t' <<< "ro:2581,1309531682152,A,Place,Page,me:2642,1310989368864,A,Place,Page,uk:2556,13‌​09267095061,A,Place,Page,me:2642,1310989380238,D,Place,Page,me:2642,1334659643627‌​,D,Place,Page,ro:3562,1378721526696,A,Place,Page,uk:1319,1309337246675,D,Place,Page,ro:2581,1379500694666,D,Place,Page,uk:1319,1309337246675,A,Place,Page"