$re = '/^(?=\D*\d)\S{6,}$/';
$str = 'deedddddddd4dffffff f';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);