# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^cache\s(\d+)"
test_str = ("cache 5764452352\n"
"rss 2929250304\n"
"rss_huge 0\n"
"mapped_file 283906048\n"
"pgpgin 19709097\n"
"pgpgout 17586611\n"
"pgfault 39612525\n"
"pgmajfault 3757\n"
"inactive_anon 160579584\n"
"active_anon 3931484160\n"
"inactive_file 3560427520\n"
"active_file 1040818176\n"
"unevictable 49152\n"
"hierarchical_memory_limit 9223372036854775807\n"
"total_cache 5764452352\n"
"total_rss 2929250304\n"
"total_rss_huge 0\n"
"total_mapped_file 283906048\n"
"total_pgpgin 19709097\n"
"total_pgpgout 17586611\n"
"total_pgfault 39612525\n"
"total_pgmajfault 3757\n"
"total_inactive_anon 160579584\n"
"total_active_anon 3931484160\n"
"total_inactive_file 3560427520\n"
"total_active_file 1040818176\n"
"total_unevictable 49152")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.