$re = '/"-\$\d{1,3}(?:,\d{3})*"/m';
$str = '-$1,200
-$750
-$10,000,000,000
-$100,000,
-$1,2
-$,000
-$1200
$1,200
$750
{"amount":1242,"amountFormatted":"-$1,242","currency":"USD","type":"PRICING","__typename":"PriceItem"},{"localizedTitle":"Fees","localizedExplanation":"This fee covers: "}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);