re = /\b\d{4}\b(?!\s?\d{4}\b)/
str = 'String String 7777 Some more string
String 1234 7777 Some more string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end