re = /\b\d{4}\b(?!.*\b\d{4}\b)/m
str = 'String String 7777 Some more 55755 string
String 1234 more text 7777 Some more string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end