$re = '/^([A-Za-z_][A-Za-z0-9_-]{0,31})(?=@)/';
$str = 'foobar@host';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);