package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)s\b`)
var str = `Dress`
var substitution = "\0 \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}