re = /([a-z]+)\1/i
str = 'Peixoto, FlorianoFloriano Peixoto", "de Morais, PrudentePrudente de Morais", "Sales, CamposCampos Sales'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end