import re
regex = re.compile(r"\s(\d{1})(\w+\W{1,2})*")
test_str = (" 1 DOPPEL TYP I MEERBLICK HALBPENSION\n"
" FRÜHBUCHER 20%\n"
" INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
" FLUGHAFEN\n"
" KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE\n"
" F367655 HERR WILKAT, CHRISTINE O 05.01.15\n"
" F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")