$re = '/^(\d{1,5}|\d{1,5}\.\d{1,4}|\.\d{1,4})$/';
$str = '23456.5432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);