import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\d]{1,3})\\.(?:[\\d]{1,3})\\.(?:[\\d]{1,3})\\.(?:[\\d]{1,3})\\/(?:[\\d]{1,3})\\b(?! is variably)";
final String string = "D 10.50.80.0/24 [90/3072] via 10.10.10.1, 3w6d, Vlan10\n"
+ "C 10.10.140.0/24 is directly connected, Vlan240\n"
+ "10.10.140.0/2\n"
+ "10.10.140.0/16\n"
+ "2.2.2.2/24\n"
+ "5.5.5.5.5/24\n\n"
+ "// Negative\n"
+ "10.0.0.0\n"
+ " 10.10.60.0/16 is variably subnetted, 58 subnets, 4 masks\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}