$re = '/^(0000:)+/';
$str = '0000:0000:0000:0000:FFFF:0000:0002:AC11';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);