#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Instrument Method\s*[=:-]\s*(?<dm>.*)"
Local $sString = "This data was acquired in Method&Run Control." & @CRLF & _
"The MSD parameters were saved in the msdiag register file." & @CRLF & _
"This msparms.txt file was built using the values from the msdiag register." & @CRLF & _
"Some parameters normally reported under MSData acquisition in Tune " & @CRLF & _
"may be missing from this msparms.txt file. You may be able to read these " & @CRLF & _
"values from Data Analysis. These items are marked with an asterisk (*)." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"File : C:\HPCHEM\1\DATA\FIA.D" & @CRLF & _
"Operator : Apps Chemist" & @CRLF & _
"Date acquired : Wed Apr 09 17:50:26 1997" & @CRLF & _
"Instrument Method : Appsprite2" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Sample information" & @CRLF & _
"----------------------------------" & @CRLF & _
"Sample name : 50 ng caffeine" & @CRLF & _
"Misc info : 50 ng Caffeine run in condensed mode varying fragmentor" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"MS parameters" & @CRLF & _
"----------------------------------" & @CRLF & _
"Tune File : C:\HPCHEM\1\1946TUNE\atunes.tun" & @CRLF & _
"Skim1 : Not Applicable" & @CRLF & _
"Skim2 : 8.0 V " & @CRLF & _
"Ion Energy : 5.0 V " & @CRLF & _
"Lens1 : 1.4 V " & @CRLF & _
"Lens2 : 27 V " & @CRLF & _
"Iris : 350 V " & @CRLF & _
"HED : 10000 V " & @CRLF & _
"Width Gain : -70 " & @CRLF & _
"Width Offset : Variable " & @CRLF & _
" Mass : Value " & @CRLF & _
" --------------------------" & @CRLF & _
" 118.10 : -11 " & @CRLF & _
" 622.03 : -14 " & @CRLF & _
" 922.01 : -2 " & @CRLF & _
" 1521.97 : -8 " & @CRLF & _
" 2121.93 : -13 " & @CRLF & _
" 2721.89 : -12 " & @CRLF & _
" --------------------------" & @CRLF & _
"Mass Gain : 4.40 " & @CRLF & _
"Mass Offset : Variable " & @CRLF & _
" Mass : Value " & @CRLF & _
" --------------------------" & @CRLF & _
" 118.10 : 0 " & @CRLF & _
" 622.03 : 0 " & @CRLF & _
" 922.01 : 0 " & @CRLF & _
" 1521.97 : 0 " & @CRLF & _
" 2121.93 : 0 " & @CRLF & _
" 2721.89 : 0 " & @CRLF & _
" --------------------------" & @CRLF & _
"Quad DC : 0.00 V " & @CRLF & _
"Octopole Peak : 300 V " & @CRLF & _
"Octopole Knee : 307 Da " & @CRLF & _
"Mass Filter : Gaussian " & @CRLF & _
"Mass Filter Width : 0.30 Da " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")