$re = '/(?:https?:)?\/\/\S++(?<!…)/';
$str = 'sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext http://goog… sometext https://go…';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);