// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"[a-f0-9]{4}-[a-f0-9]{6}-[a-f0-9]{12}-[a-f0-9]{5}-[a-f0-9]{9}").unwrap();
  let string = "4be3-eda97a-0d7faeab05a0-89403-ad4751c49";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}