$re = '/^[0-9]{5}(-[0-9]{4})?/m';
$str = '90210
02134
12345-6789
H0H-0H0
SOUTH DAKOTA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);