package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`le`)
var str = `il est la le toot`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}