const regex = new RegExp('(?:^#\\s+Input|\\G(?!\\A))\\R*(?!#\\s+Output)#\\s*(.*)|[\\s\\S]*', 'gm')
const str = `# Input
# data/raw/file1
# data/raw/file2
# Output
# data/interim/file1
# data/interim/file2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}