$re = '/^\.?([a-zA-Z0-9]+_)?(foobar)\.txt$/m';
$str = '_foobar.txt
.foobar.txt
.bcd_foobar.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);